We have completed our monitoring and can confirm that this incident is fully resolved. All emails are being delivered successfully and no further issues have been detected.
Email services are operating normally. No action is required on your end.
We apologize for any inconvenience and thank you for your patience.
Posted May 28, 2026 - 13:09 UTC
Monitoring
We have identified the root cause of the email delivery issues and applied a fix. Email delivery is being restored and we are actively monitoring the situation to ensure full stability. Some previously delayed emails may be delivered in batches over the next few minutes.
We will continue to monitor and provide a final update once the incident is fully resolved.
Posted May 28, 2026 - 13:02 UTC
Investigating
We are currently investigating an issue of emails not being delivered. Some users may experience missing notifications, confirmation emails, or other email-based communications.
We will provide an update within 30 minutes as our investigation progresses. We apologize for any inconvenience.